Solucionando problemas: restablecer tema por defecto de gdm en Ubuntu 9.10

20 05 2010

Tocando todos los botones (como suelo hacer cada tanto) en la pantalla de inicio de sesión de Ubuntu (gdm), terminé probando en ‘Accesibilidad’ la opción del alto contraste…

El resultado de esto fue que el tema de metacity para gdm cambie a Clearlooks con colores oscuros. Ningún problema muy grave, si no fuera porque, al desactivarla, no volvió al tema que tenía, sino a Clearlooks clarito.

Pasaron meses así, resignado. Hasta que estos días actualicé gdm (apareció en el Gestor de Actualizaciones), y el theme original volvió a aparecer.

Así que, así era la solución: reinstalar.

# sudo aptitude reinstall gdm

Salutes!

Update 23/05/2010:
OK, sí… es una solución muy windowsera esa… Así que me puse a buscar dónde estaba la papa, y el tema está en el archivo /var/lib/gdm/.gconf.defaults/%gconf-tree.xmlLee el resto de esta entrada »

Anuncios




Solucionando “Salida boba” en Ubuntu Karmic 9.10

10 01 2010

Instalé Ubuntu Karmic 9.10 desde cero (ok, antes había upgradeado desde la 9.04, pero después formateé e instalé desde cero), y después de un tiempo note que no tenía sonido.

Después de un tiempo más, noté que en el gestor de sonido que aparece al lado del reloj me decía que la salida de sonido actual era la “Salida boba”.

Google mediante, encontré que la solución era “abrir Synaptic, buscar ‘alsa’, y reinstalar todos los paquetes que aparezcan ya instalados”.

Probé, y fue cierto, pero era una solución no muy convincente: al reiniciar la máquina volvía el problema, y tenía que insistir con la “solución”. Reinstalar cerca de 10 paquetes para que funcione el sonido no me cae bien.

Empezé a afilar el ojo, y noté que la diferencia estaba al reinstalar el paquete “sl-modem-daemon”, un paquete de alguna forma relacionado con mi módem telefónico Smart Link.

Primer solución: agregar un lanzador a “sudo aptitude reinstall sl-modem-daemon”. No era lo más feliz, pero el sonido volvía.

Buscando un poco más, quize tener una solución copada, pero no la conseguí. Aún así, encontré algo interesante: desinstalando el mencionado paquete, el problema desaparece, por lo que no hace falta tocar nada para que el sonido funcione de entrada.

Aún así, supongo que desinstalar ese paquete me inhabilita el módem, por lo que no es demasiado feliz, igualmente. De todos modos, el módem telefónico no suelo usarlo, por lo que supongo que seguiré así, guardando el .deb del sl-modem-daemon en alguna carpeta, para salir del apuro el día que lo necesite.

Si alguno tiene una solución mejor/real, bienvenida será.

PD: por si a alguno le interesa, pueden bajar el paquete desde http://ubuntu.mirrors.tds.net/ubuntu/pool/restricted/s/sl-modem/sl-modem-daemon_2.9.11~20080817-3ubuntu3_i386.deb

O desde cualquier mirror de esta página.